Incidents

Sandbox API Disruption: Create Recipient and Payment Initiation

resolvedMAJORaffectedRedpin Sandbox Environmentlasted 1h 50s

Following continued monitoring, all services have returned to a healthy state. We are now resolving this incident. Thank you for your patience throughout.

resolved
Apr 27 11:25:50 (UTC)

All monitors have recovered, and the affected APIs are now functioning normally. We will continue to monitor the environment closely to ensure stability. Thank you for your patience.

monitoring
Apr 27 11:19:30 (UTC)

We have identified that the Keycloak unresponsiveness was caused by an underlying database issue. The application was unable to establish connections to the database, as it was in a locked state due to a few long-running queries from a scheduled job. Our team is working on resolving this and restoring normal service. Further updates to follow.

identified
Apr 27 11:10:20 (UTC)

The issue has been traced to an unresponsive Keycloak instance in a downstream service. The team is actively working on a fix in the Sandbox environment. Further updates to follow.

investigating
Apr 27 11:09:19 (UTC)

We are investigating failures affecting the Sandbox APIs for recipient creation and payment initiation. Updates to follow.

investigating
Apr 27 10:25:00 (UTC)