Degraded API performance

Started
Lasted 1h 45min
MAJOR

Updates

RESOLVED

lasted 1h 45min

The issue has been resolved with one of our downstream services.

APIs should be back to normal now.

IDENTIFIED

1h 45min earlier

We have received alerts about slow responses from our APIs. Some requests are failing with Gateway Timeout 504 errors.